View Full Version : Problems with SB 3.6.36

05-07-2011, 08:48 AM
I installed a new hard drive on my computer and decided to install the latest version of SB. I had been using SB 3.5.18. I often use the keyboard commands to raise and lower the Z axis for bit changing. When using the page up or page down key with SB 3.5.18 the Z stops as soon as I release the key. With the new version the Z coasts to a stop. I don't like the coast, I want to have accurate control of where the Z stops.
Also, I typed JY 24 to move the spindle and decided to stop the movement by hitting the Spacebar. The movement stopped but I could still hear the Y motor. The software was locked up. I hit ESC to close but it wouldn't close. I used the Windows Task Manager to shut down the SB software.
These problems led to my uninstalling SB 3.6.36 and reinstalling SB 3.5.18 which has worked perfectly since I first installed it

10-08-2011, 11:09 PM
I am having the same problem but don't have the older version, do you know if they updated it to fix this issue?

10-09-2011, 05:55 PM
I had to fall back to rev 3.6.14 to get the keyboard moves to stop promptly. Several people have reported problems with keyboard moves in the past, but as far as I know ShopBot has never acknowledged a problem. Others have told me it is my computer! If that is the case, why does 3.6.14 work?

10-09-2011, 08:01 PM
I had the same problem with 3.6.36 along with a few other problems. My rule is: Isn't broke leave it alone. Fall back to what works for you.

10-10-2011, 09:55 AM
I went back to the older ver. It works very well.


10-10-2011, 10:01 AM
I have the same problem.... wish there was a fix

10-10-2011, 01:04 PM
Maybe Shopbot has that answer for us. I too would like to upgrade.

10-10-2011, 02:58 PM
It may be related to the vintage of the controller. I upgraded a few of them that had to use the older serial to usb converter and they all had issues with the version 36. I rolled them back and they worked fine.

Then I did a recent 4g upgrade for someone and the older version didn't work well. 36 ran great on the new 4g board with the latest and greatest.

It's just a hunch based on upgrading several machines.

10-10-2011, 04:23 PM
A possible work-around...

I've found on my PRT Alpha, That when using the keyboard keys to jog, if I use the [control] key with an arrow key it of course moves a jog speed BUT also stops instantly when I let go. Not so when using the arrow key alone. I find that this is the way I'm jogging with out even thinking about it.


10-11-2011, 03:22 PM

I loaded 3.6.38 to test the keypad moves. And as you observed with the cntl key down the moves stops without the delay. But when trying to do small moves (as finding the surface for a zero) with the cntl key down it makes larger jumps than I would like. So back to Ver3.6.14 for me until ShopBot can fix the problem.


I recently upgraded Jerry's machine with a new USB controller and he has the same problem. So I don't know if it's the serial vs USB controller.

10-11-2011, 11:24 PM
I have a 4g box and we still had problems.