View Full Version : FG command in preview vs move/cut

06-18-2012, 03:09 PM
Today a file froze up. I was trying to use the FG command to resume at line 16802 which occurs in the file after several mtc's. When I use FG in preview and then select 'skip to' and enter the number it runs thru all of the code up to that line. However when I try to do the same thing in move/cut (select 'skip to' enter the number, hit 'go') it starts to run thru the code but stops at the first tool to ask me if it is in the spindle, then proceeds to prompt for zeroing...

Does this sound familiar to anyone?

06-18-2012, 03:29 PM
The tool change routines have code in them that detects if you're running in preview mode or cut/move mode.

So when you were in preview mode those prompts would have been skipped over.

06-19-2012, 09:50 AM
Thanks Adrian,
So if you want to pick up where you left off after several tool changes, can you get the FG command to skip over the non required tools? If not, it seems you can't really skip ahead, rather you just have to start over and aircut where the wood has already been removed.

06-19-2012, 10:30 AM
I don't know how others might address this, but when I had a tough file issue and had to shut down, and could not get my FG command to function ( I had an error in the file, and it took me a while to work out where my problem was and to get on the phone with Frank to help me get it fixed...)

SO to work around my problem, I went into file edit mode, brought up the file I wanted to work with, and copied everything from the line I wanted forward to the end and pasted it into a blank file. Then I went back and pulled/copied the header information (description, tool info, move speed, etc) in case I ever needed to run this file from just this spot again. (The file was an hours long 3D carve I didn't want to have to try to time it and get to the exact line of code, etc). I saved off the new file and then made the first position XXX,YYY- where I wanted to prcoceed from ( vs. (0.000, 0.000). This is NOT to say that I reset the XY Zero to the new location... Just that the machine was made to recognize the need to start from that location, not 0,0. I moved the bit to the new X,Y start location, then I ran the new file (could have left it at 0.000, 0.000, but had had previous trouble restarting a file and having the bit travel down into the material while moving to the start point...didn't want to risk that again.)

It worked like a charm.

Even if you have errors in your user settings or something, you should be able to run the balance of your file this way- as long as you have not lost your "zero".

Good luck!