View Full Version : How to stop the machine from returning to 0,0 between multiple toolpaths

11-18-2012, 02:03 AM
Hi, Just like to know how I can stop my PRS Shopbot from returning back to 0,0 in between multiple tool paths. I'd like it to go from one toolpath to the next but it seems to jump back to 0,0 in between finishing one toolpath and starting the next.

As you can see via the 3d render it returns home after every toolpath. I have included the .sbp file if that is any help.

I'm sure it is an easy setting in Partworks or Shopbot but I never encountered this issue on the CNC Shark.


11-18-2012, 03:03 AM
Modify the P.P. to eliminate the "home" command...

11-18-2012, 04:37 AM
Modify the P.P. to eliminate the "home" command...

Is that something that can be modified once to affect all files or will it need to be edited every time I create a new .sbp file?

11-18-2012, 07:47 AM
Look on the VCarve Help menu and you will see a Post Processor editing guide.

If you modify the Post Processor then it will affect every file you create from that point on. You won't need to change anything after that.

11-18-2012, 08:01 AM
Thanks Adrian. I took a look at the editing help file but it was a serious wall of text. So I might phone support on Monday and see what they say and how I go about changing it.

Is there an advantage to have it going back to 0,0 between multiple toolpaths?


11-18-2012, 09:03 AM
Are you running the latest Post Processor?

I have my own modified one but I've just looked at the latest standard one and it doesn't return to home after each toolpath with the same tool and there is a comment in there that says the issue was fixed in 2011.

When you download the control software the latest Post Processors are in the c:\sbparts\partworksposts folder.

11-18-2012, 03:10 PM
Interesting that it only seems to be the case in the Toolchange posts...

11-18-2012, 05:16 PM
There are only two post processors these days. One metric and one imperial. They include all the toolchange, speed control and arc functionality that used to be spread across different ones.

11-18-2012, 05:35 PM
9th December 2011 is the date of post processor file.


11-18-2012, 05:53 PM
I have recentlyu gone back and searched older files that do this, and will go to the first lines after the new header for each of the cut instructions and will delete the "J2,0.0000, 0.0000" line of code. This basically allows you to use an old file without going in and recalculating everything with the new software ( and gosh only knows if it would apply the new PP...) ---

If you delete just this line ( and I also make sure to delete the blank line that is left from deleting the text. I don't think it is necessary, but it is cleaner and neater.)- you essentially ask the machine to move from the last cutting instruction, to the point of the next instruction. There will be a JZ that moves the Z to a safe Z height before this line of code begins, so all you are doing is eliminating the move to 0.00, 0.00 before starting the next cut. if you have a long distance to travel to get back to home, or several segments that must be cut in each file, you will definitely save a ton of time. I shaved off 12 minutes off a 48 minute cut file by looking closely at the steps I NEEDED to perform vs the steps the machine was programmed to perform due to the selections and speeds I had made when designing the program. For a series of cuts that I intend to repeat MANY times- this was a very valuable exercise. It took me some time to figure out which cuts were important to me and which were not... but once I made the initial investment of time and testing, I can save 12 minutes everytime I run this file (which I anticpate to be as many as 50-60 times over the next year or so!)

11-18-2012, 11:01 PM
0,0 may not always be the best place for the home position.

Often the home position may be more near the middle of the work in a location where you want to change the bit when it is needed.

11-19-2012, 05:48 AM
Thanks everyone. I think I've solved the issue. Even though I had the latest PP file it wasn't placed in the right folder. Why it doen't put the new PP file in the right place when updating the software I'm not sure. Kinda frustrating when these little things are stopping me from getting the full enjoyment from my Shopbot.

Changing to the latest PP file in the correct folder and now it doesn't return to 0,0 between toolpaths which is just what I wanted.


11-19-2012, 11:28 AM
They would get way more complaints if they overwrote people's modified PP files with the new OEM version than they do this way.

Maybe they should ask whether you want your PP files updated or not when updating the software.

Glad you got it figured out.