View Full Version : Need help with Aspire 8.5

JMC Design & Fabrication
06-06-2017, 03:26 PM
Had Aspire and shopbot Alpha for 4 years. Every time I create a 3D model with raised text I get lines carved into the model. It doesn't show up in the preview. I've tried the add feature as well as the merge. I can remove the text and run the same file without problem. It's only with raised text. This is nothing new. Been dealing with this since day one. It's not a machine or bit problem. Can anyone help. Attached a photo. Hope I did that correctly 30324

06-06-2017, 04:42 PM
It probably is a machine problem. Do you have a 'Standard' machine? What are the feed rates set to for XY and Z. Are you running the default ramp settings when doing 3D files?

One thing you can do with this is to add a draft to just the text (and border if needed). About 10%-15% will add a slight angle to the sides and allow the Z axis to ramp up and over instead of a stop/up/stop/down motion, of which can cause lost steps in the Z axis on Standard machines.

Joe Porter
06-06-2017, 04:52 PM
You may want to post this on the Vectric forum. It looks like there is a raised platform with the letter at the end of it. Maybe if you looked at each individual letter in the component tree and hi-lited each one individually and check the size and make sure you are only adding a letter and not a letter sitting on a base...I don't think the lines are being carved, I think the lines are the result of not carving the letter (with the base?). Hope this is of some help...joe

Gary Campbell
06-06-2017, 05:48 PM
I'm with Scott on this one. A machine problem. Check the Z pinion grubscrew, seems too uniform to be loss of steps. Especially since it has done thins since day one.

JMC Design & Fabrication
06-06-2017, 06:06 PM
I have an Alpha. It's just when I add text to the models. If I purchase a model that someone else did, and it has text, it does fine. So you are saying I can't just add text and bake the model. I need to add a slight draft to it? Makes sense. I'll try it

JMC Design & Fabrication
06-06-2017, 06:09 PM
Not sure what you're meaning when you say base but having did that, it does sound like that's what happened

Joe Porter
06-06-2017, 06:24 PM
Not sure what you're meaning when you say base but having did that, it does sound like that's what happened
I think your individual text letters have some extra baggage with them and is showing up in your cut. You mention the preview looks good, are you previewing the toolpath operation? Usually if that is good, the finished product will be good, unless there is a machine problem. I'm sure you are, but just needed to ask...joe

06-06-2017, 08:56 PM
If I may add my thoughts,,, I suspect you model resolution is set to "Standard"...if so, create a new file with a higher resolution (Very High) and see if that makes a difference.
Don't use the same file,,,the properties will be carried over.

A pixel based program will have some oddities on how it calculates the toolpaths.

JMC Design & Fabrication
06-06-2017, 10:20 PM
Resolution is set to very high. Nothing shows up on the preview. It doesn't leave any stray lines on anything else but if I add text it does this. Different models have different lines but you can look at it and tell it has something to do with the text. The lines align perfectly with top or bottom of the letters. If it was a mechanical issue it should affect everything I cut but it doesn't. I'm at a loss

06-07-2017, 06:53 AM
I'm with Gary. Check the Z axis. Solved an almost identical issue on a PRS due to the Z axis bearings being too tight. I pulled the stepper and adjusted the bearings to gain free movement by hand.

Also had one where the pinion was set too far out on the stepper shaft and at one particular point it would contact the Z axis beam. That was enough to slow the axis giving the appearance of lost steps. Reset pinion and problem disappeared.


06-07-2017, 10:34 AM
I don't think it is the machine as the areas that are not cut deep enough are consistent. If it was the machine they would be different depths

06-07-2017, 11:35 AM

As I said, I solved an exact issue by adjusting the Z axis on the machine. Before doing so I ran the exact same toolpath that was causing this particular problem on another Shopbot and it cut without any issue. This ruled out Aspire and the toolpath as the culprit. That is not to say that SB3 control software doesn't have a hand in it. At least have a look at it.


06-07-2017, 12:35 PM
If it doesn't show up in the 3D view of your model and it doesn't show in the toolpath preview in Aspire, then take it one more step and preview it in the ShopBot Previewer. Look at the results of it with the tool applied and run, but also just look at all the blue toolpath lines that are shown. By zooming in to the problem areas, you should be able to see if there are lines that are higher in the 'flat' regions behind the letters and lower in the space between the letters. You can hover over the lines and read the XYZ values as well as the line of code it's on at the bottom of the viewer.

If you don't see the issue in any of these methods, it could be a machine problem. Since you have an Alpha, you shouldn't lose steps so take a look at the grub screws per Gary's suggestion. With ramp values that are at default or not optimal settings for 3D, when it gets to a letter edge, it jerks up abruptly and could shift the position of the shaft in the pinion. Granted, it seems that the area would be low instead, but the shaft could go both ways and maybe at the other side of the letter, it's on the opposite side of intended value.

Post the file if you can for us to take a look at. If not here, google drive, onedrive, dropbox, etc.

06-10-2017, 12:50 AM
I would wager mechanical problem too.

Wouldn't hurt to try a different font, if you haven't already ,,, And add a zero plane.