View Full Version : Phantom Problem

03-19-2003, 09:24 PM
I hope this is not a duplicate of an existing thread, I could not find another that matched. Here goes...
I am running a PRT96 that I recently purchased used. As I understand from ShopBot, it is an early control board. I am still learning, so I am prone to mistakes. I first noticed a problem with my Z-axis losing its zero reference. I always zero to the top of the spoilboard and then cut to zero. Occasionally, the tool bit would go below to -.120 when told via the cut file to go to -.010. It seemed to be quit intermittant, but when I ran the z-zero routine, all was fixed. Today, I notice that the pattern that I had been running successfully for some time, was now cutting incorrectly. The stepping in the Y direction was good, but too short in the X direction. I checked the scaling numbers and found that the X number was different than the recommended number. It had changed to 120. All this info leads to a basic question: Does this information get stored in memory for use by the program, or does the program read the value from hard storage (disk) whenever it needs it? In other words, could noise pulses generated by the stepping motors or the router couple to the control board or program space in the PC and cause this value to change dynamically? I have now run ground leads to each of the motors and then to a water pipe that is near the machine just in case. Tomorrow I will purchase a shielded serial cable to reduce the coupling on that interface. Does any of this make sense to you experienced Botters?? Thanks in advance...Frank

03-19-2003, 10:00 PM
It's posible that your steppers are loosing steps . This can be caused by running too fast , too deep ( too much load ), or binding. If you have a ball screw z axis check the rollers and make sure that they are not binding , or loose . Also keep the ball screw clean , Shopbot does not recomend lubricating it but I regularly spray mine with Bostick dry coat ( saw blade lubricant ) You can also check the x frame for spots that are binding . If you suspect the vu settings are changing write them down , and check them again using the vu command

03-20-2003, 03:34 AM
Frank, we havn't had problems with unit values changing by themselves, but we have had problems with steps getting lost/inserted at random. Ours is one of the first PRT's (Sept 2000).

Problem was bad grounding of the router bearings/collet, as crazy as this may sound. Our "router" has only two wires (no ground wire) with an intrinsically safe plastic case. But it is really a die grinder with a long metal casing at the nose. The collet shaft has a plastic coupler to the armature so that the metal casing system is intrinsically safe from the electric side of the motor. When we grounded this metal extension, all our problems went away - (we had to ground it for the zero plate.)

03-20-2003, 07:26 PM
Thanks for the help, I am convinced it is due to electrical noise. Unfortunately, I'll only know if the problem doesn't come back... Today I grounded all of the motors to the gantries and the gantry to the control box. I also got a shielded serial cable. Now I'll see if things improve. I was hoping someone from ShopBot could check the possibility of the settings being changed by noise pulses. I would hope that the values are held in latched control registers, but maybe not...

03-21-2003, 01:16 AM
We made sure that we grounded ALL the "gantries". The moving gantries included the z-slide, y-car, y-gantry. In other words, do not rely on the bearings (of the router) and the rollers (of the gantries) to make an electrical ground path - put cables/wires across them. And don't be shy to use a thickish cable.

(Somehow I think that your seperate ground to the water pipe may cause more problems. Some equipment doesn't like having two ground paths. Rather take it all to the ground on the control box and make sure that has a normal path to your electrical outlet)

I recall a grounding service note published by ShopBot somewhere in the last year......?

03-30-2003, 07:14 PM
Mysterious Z move : I have an older r&p utility strut shopbot that has served me flawlessly for about four years . I created a text file in v carvz , exported to vector and then created a toolpath . Somewhre near line 13,000 the Z axis started moving vertically . I was doing something else at the time the file was running and didn't notice the z moving to the top of it's mechanical limit , but when I did notice it the Z value on the screen was at 120 " . I went cross eyed looking for the move with the text editor , checked the values in the vector file and they were all fine . I then cut the text file in half and tried it again . ----Somewhere after about ten thousand lines the z started heading for the ceiling again . I tried setting the software limits pretty tight using the vl command and running the file in preview mode . --I can't find an error in the part file , but there is something weird happening with the z axis . ----Anybody have any ideas ? Thanks Mike

05-18-2003, 04:37 PM
Similar problem to Franks on a little used 6 month old PRT96 working in metric. It frequently loses Z axis reference and does shift the zero, again zzero rectifies the problem immediately. On one occasion I have had the short y axis problem as well. Have checked the scaling and this seems to be okay. Any conclusive help appreciated.

05-19-2003, 01:31 PM
It could be that there is a 3D arc in your toolpath somewhere. The Shopbot software doesn't like this.

Try break, interpolate to break any arcs into line segments.

05-19-2003, 03:08 PM
I had the same problem with the z-axis (machine is 8 months old. To fix the problem I grounded the machine and added a line conditioner (Apc 1250 Line R). All Z problems disappeared.

05-19-2003, 03:42 PM
Why all this talk of grounding ONLY for the z-axis and not the x and y? Well, because the cable to the router runs parallel to z-axis motor cable for a long distance. There is a much bigger potential for electrical interference dumped by the router into the z-axis control circuit, than into the other motor circuits.

Sheldon, we havn't noticed the 3D arc problem yet - thanks for warning of its existence.

05-20-2003, 10:04 PM
I have not been to this forum in a few weeks, but just to update all on my past phantom problem. Since I grounded all of the gantries, the phantom problem has not reappeared. By jove, I think I've got it....

05-21-2003, 02:04 AM
Frank, you've made my day!

Sometimes I think that I make tons of suggestions and nobody takes any notice - it's great to hear somebody come back to the board and say: "that worked".