View Full Version : Trouble in VECTOR-dise

03-06-2001, 06:21 PM
Using vector for creating my toolpaths has been an easy learning curve. It took me aprox 1/2 hr to generate my very first toolpath and now five weeks later for something similar it only takes maybe three to five mins. I like the product for that purpose, however today something strange occured and it has me as well as Dave from shopbot scratching our heads. Yesterday, creating tool-paths was, like I said a five min. tops process...today couldn't do it at all!!! When I get to the part of the process where I press the Insert command (the green machine icon with the blue arrow) the dialog box for drivers comes up alright and there is the SB driver I click "OK"
then nothing...in the past what would happen is the computer screen would split into two separate screens and then I would press the generate NC command and Voila a long file would appear on the left screen...and now today NOTHING...HELP!!!

03-06-2001, 07:10 PM
If it happens again, try the "Windows-Tile Vertical" command afterwards. Sometimes the software fails to split the screen for you and the window that you are used to seeing just isn't visible.

If it isn't that, there's always the old reliable restart and run Norton Utilities.

Keep us posted.

04-05-2001, 12:30 PM
Rodney failed to mention WHICH VERSION of Vector he was using, when he experienced the error...
We are using Vector-8 with no problems,
however Vector NINE is often refusing to generate the NC code: when we click on 'MACRO', nothing happens.. i.e. no drop-down menu appears.
yeah yeah, it's probably something we forgot to do
but if anyone else is having similar problems(of any sort?) with Vector NINE, discussion would be most welcome.

04-05-2001, 02:56 PM
Those that have purchased version 9 should receive an updated CD within the next week or so. The previously mentioned problem with generation of the SB codes on each line was a configuration setting and has been replaced with a new file on the CD's. Two minor problems with access to the Edit menu after NC generation and availability of the Wrap cylinder function after deleting one were repaired. I have not heard of the problem that you are discussing, and would appreciate if you could elaborate & possibly send us exactly the steps that cause the problem.

As always we welcome you to ask about Vector specific problems at the IMService Vector user's forum at http://www.vectorcam.com under support

04-06-2001, 02:26 PM
Hi, Fred:
-thanks for the response.

We seem to have Vector NINE working okay on a Windoze 2000 machine,
but not on the Win.98machine!
-could THIS be the difference??
-Operating Systems?

As explained previously(albeit briefly) we're drawing the usual cut-files, 'Inserting NC',
whereupon the screen splits into the usual two bits,
but when we click on "MACRO" (on the Win98 comp)
NO DROP-DOWN MENU APPEARS(to allow us to select the usual macro Start command, etc.)

Again, I assert that Yes,the Macro drop-down menu DOES happen on the Win.2000 machine, and we are generating what appears to be normal code, under Win.2000::

but due to no Macro drop-down on the Win.98 machine, we can proceed no further.

'Nuther thought.... on the Win.98 machine, we have BOTH VERSIONS of Vector (8 as well as 9) installed.
along with both drivers..
Shopbt2d.cfg for v.8
and Shopbt2e.cfg for v.9

Could this 'duplication' (of both software AND drivers)be the cause of our problems?
Some computers dislike having different versions of the same software,made by the same maker, on the same hard drive!
Is this the case with us??

04-06-2001, 04:57 PM
Vector may not like to run V8, then V9 or the reverse, as some of the DLL's have the same name between the different versions. You should reboot between using the different versions. Make absolute certain that you only upgrade files. Don't try to use version 9 files with version 8.

You may have the wrong configuration with version 9. When you insert NC, make sure that the Shopbt configuration, whether D or E, has iso001 in the driver window.

Can you generate NC code? Maybe someone accidentally deleted the menu items from the configuration. If that is the case, simply reinstall the Shopbot Config file and you should be back where you started. Note that you may have the one that requires the addition of the "test" cycle, and the clicking of the non modal option. I described this in another recent thread here, and in great detail on the Vectorcam forum on March 8th.

Shopbt2f.cfg is on the new CD to make it clear that it does not require any modification. It will only work for Version 9 and care should be taken to make sure that it is never used with Vector 8 or earlier.

04-07-2001, 09:18 AM
You old rascal, are still blaming everything on Windows. I know you're up in your little office (where I spent happy times) with the air on while every one else is sweating. Turn off the air, open the windows and turn up the heat. That will make it work.

Seriously, have you been able to generate the code yet. I guess I gave you guys a bum disc. How is the circular ceiling going? Must be you guys are programing and cutting up a storm, since I don't hear much from you. By the way try "jooking it". I hope I remember at least that much Bajan.

John Forney

02-17-2002, 11:52 PM
I just tried to install Vector 9 on my laptop. The install was was done off CD as the laptop has no floppy drive. I edited the initiate file to copy from the appropriate drive to the appropriate folder. When I try to run Vector now, I get a message that reads like this:

srvr: ntvdm.exe Application error. Instruction at "0x77f52cd0" refferenced memory at "0x020a03ff" The memory could not be written. Click close to exit.

Is this caused by the fact that the initiation was done from a copy of the floppy or is there another issue here? How do I resolve this. I have not tried to install from the floppy across my network, but think I can do this if it will work.

Help!!!! Perry