can’t remember if “safe z” height is an SB setting or something set in your CAM software.

I’d check SB settings to see if you some crazy number set for the z axis.