Results 1 to 6 of 6

Thread: Plunge to surface after CR

  1. #1
    Join Date
    Jun 2010
    Edmonton, Alberta, Canada

    Default Plunge to surface after CR

    I was wondering if anyone has ever experienced this when running a CR or table resurfacing?

    After finishing the cut my Z returns home then plunges (fast) to zero while the router is still running before turning off the router. It's quite unnerving watching a rapid plunge touch the surface of a freshly surfaced table. I've looked through the file & can't see why it's doing this.

    Here's the code in my surfacing file:

    IF %(25)=1 THEN GOTO UNIT_ERROR 'Check to see software is set to inches
    SA 'Set program to absolute coordinate mode
    JZ,1.00 'Jog Z axis to safe height
    JA,2.00 'Jog A axis to safe height
    J3,0,0,1 'Jog to start position
    SO,1,1 'Turn on router 1
    PAUSE 2 'Give router time to reach cutting rpm
    SO,1,0 'Turn off router 1
    C#,91 'Run file explaining unit error
    Last edited by sbd1; 10-28-2012 at 01:06 PM.

  2. #2
    Join Date
    May 2005
    Fox Bay Industries Inc., Auburn WA


    Daren, When I surface my table, I use the CR mode and it does plunge back to zero. I did not really notice that it is at a rapid rate. I am using a PC router and I just turn it off before it gets to that point. When I run the CR file, I set it up to plunge from Zero, so the tool is already at Zero. Then the tool returns to where the file was started. Just my 2 cents. I will be following this thread and learn something. I'm sure one of the regulars will know. Wayne

  3. #3
    Join Date
    Oct 2000
    Atlanta GA


    Instead of using CR to surface your table, you can create a pocketing toolpath in PartWorks or Aspire, and have much more control over the tool movements, without the return to Z0. Even better would be to draw a back-and-forth set of vectors and use a Profile toolpath, so you can surface using just back-and-forth motions instead of a pocketing motion. Fewer changes of direction means less ramping and faster surfacing.
    David Buchsbaum
    Beacon Custom Woodwork, Inc.
    dba Atlanta Closet & Storage Solutions

  4. #4
    Join Date
    Jun 2010
    Edmonton, Alberta, Canada


    It appears that this "plunge at end" is a known feature of CR, but it's something I'm not comfortable with. So I've been looking into Paco's 'surfacing_along_XorY_axis.sbp' file after reading about it's virtues & it seems like a good alternative to CR. I believe that you (David) said in one thread that it was one of your most commonly used files. I look forward to trying it for surfacing next time.

    I've already tried testing it with some air cuts though & it's not cutting as expected. Here's what's happening:
    - I tell it to cut (a rectangle the size of 12" X by 6" Y) along the X axis.
    - It cuts one pass 12" along the X axis & stops (then asks if I want to cut another [which if I said yes, would be deeper but in the same X path]).
    - It seems to be missing the stepover command somehow (which I set at 80%).
    - It does the same thing if I reverse the 'cut along' axis from X to Y.

    I've looked at the code & believe it's coming from this section, but would appreciate some help identifying exactly what to change as I'm still fairly new with editing files. The file I have says "'PACO - 2007" at the top so maybe it's not the latest version. Thanks.


    PRINT "Now at "; &depth; " of an inch deep."
    J3,&start_x - &tool_radius,&start_y,0.03 - (&depth - &stepdown)
    M3,&start_x + (2 * &tool_diam),&start_y,-&depth / 2
    M3,&start_x - &tool_radius,&start_y,-&depth
    MX, &start_x + &x_size + &tool_radius
    &yvalue = %(2) + &tool_stepover
    IF &yvalue > &y_size THEN GOTO FINISHED_X
    MX,&start_x - &tool_radius
    &yvalue = %(2) + &tool_stepover
    IF &yvalue > &y_size THEN GOTO FINISHED_X

  5. #5
    Join Date
    Dec 2000
    Thorp, WI



    Here's the version I've used in the past, maybe there's something missing in yours, but this one worked with what I think were your settings.

    2.75 diameter cutter at 80% stepover (just going by the VC setting in your first post)? Perhaps you have a value that is larger than your rectangle y size so it thinks it's done.
    Attached Files Attached Files

    "It’s easier to fool everyone than it is to convince them they've been fooled" - Mark Twain

  6. #6
    Join Date
    Jun 2010
    Edmonton, Alberta, Canada


    Thanks Scott. I compared every line in your file with mine & they're basically the same (it looks like you have spindle speed lines that I don't). So then I re-ran mine a few more times & figured out what works & what doesn't.

    You're correct, I'm using a 2.75" dia. bit with 80% stepover.

    If I tell the file to surface an area 12" X by 10" Y it does one pass & then ends (my original problem). But if I tell it 12" X by 20" Y then it works as expected. I also tried changing the bit dia. to 1", but that didn't make any difference. So I still don't know what the problem is, but at least I get to see it working.

Similar Threads

  1. 3D Z plunge?
    By angelosart in forum ShopBot Buddy
    Replies: 8
    Last Post: 07-26-2013, 02:06 PM
  2. About to that the Plunge
    By crash5050 in forum ShopBotter Message Board
    Replies: 10
    Last Post: 07-19-2012, 04:23 PM
  3. Plunge cut into MDO
    By cartar929 in forum Sign Making
    Replies: 3
    Last Post: 12-02-2009, 03:43 PM
  4. Well I took the plunge
    By menewfy in forum Archives2007
    Replies: 5
    Last Post: 05-15-2007, 11:30 AM
  5. Z won't plunge into surface
    By wesday in forum Archives2005
    Replies: 2
    Last Post: 07-26-2005, 08:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts