Results 1 to 2 of 2

Thread: Spindle control on PRT alpha with Windows 10

  1. #1
    Join Date
    Jan 2011
    Location
    Marietta, Ga
    Posts
    17

    Default Spindle control on PRT alpha with Windows 10

    I've been having trouble with my computer so I got a new computer, however, the new computer is running Windows 10 and the old computer was running Windows 7. The Shopbot is an older PRT alpha and so it requires the 3_6_46 version of the control software.

    Everything installed and the ShopBot Consoles comes up fine and I can control the ShopBot. The problem is that the spindle control tool can't find it. In the Driver Manger, the spindle control is listed in "Other Devices rather than in the Ports section (like it was on the old system). I've reinstalled everything (including Windows 10) a few times and always the same.

    Is the PRT alpha spindle control software compatible with Windows 10 or do I have to go get a computer that will run Windows 7 (this "new" computer won't run Windows 7).

    If the spindle controller works with Windows 10, does anyone have any idea what I need to do to get the Spindle RPM Control to recognize the spindle controller?

    I've installed the ShopBot software many many times over the past 10 or so years so I'm pretty confident that I've done the installation right, just doesn't work with this new computer so I thought I'd reach out to the forum before I go get a new computer, again.

    Thanks

  2. #2
    Join Date
    Jan 2004
    Location
    iBILD Solutions - Southern NJ
    Posts
    7,824

    Default

    Yes, it should work with Win10.

    In my experience, certain Win10 computers are problematic getting the device drivers to 'stay put'. You may have to install the drivers for it manually by going into the Device Manager, finding the controller in the list & then Update Driver. Navigate to: C:\Program Files (x86)\ShopBot\ShopBot 3\Drivers and see if it finds it. Like I said, it might take 2 or 3 tries with a restart to get it to stick.

    Additionally, go to the Power Manager and Advanced Power Settings. Turn off screen saver, leave hard disks and display on always and go down to USB & disable USB Selective Suspend. USB SS turns off USB ports to save power...you don't want that.

    -B
    High Definition 3D Laser Scanning Services - Advanced ShopBot CNC Training and Consultation - Vectric Custom Video Training IBILD.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •