Went to start up the PRS standard today and the laptop can't communicate to the shopbot.

It's acting like the usb connection is faulty. I've tried all of the following..

Tried a different laptop.
Used another usb cable.
Found a fuse blown in the power box of the Shopbot and replaced it.
numerous reboots and restarts of laptop/s and Shopbot.
Tested all other fuses and they seem to be fine.
Getting all correct led lights (I assume) on mainboard and controller card.

At a loss to what it can be. We did get a storm the other day with a couple of very close lightning strikes. But machine has an physical isolation switch and machine was not in use at time of the storm.

I'm in Australia so after hours tech support tried to help via email but will have to try and call them midnight my time to get further support.

What would normally be the cause of my issue? Could my controller card be faulty?

Machines still turns on fine and the VFD starts up along with the fan for the HSD. It just can't communicate to the software on the laptop.

The machine has been pretty much faultless for years. I will get the occasional issue that it can't connect to the Shopbot but that is usually caused by the USB cable getting moved etc and a quick unplug and plugging of the USB cable and everything is back to normal.

Any help or tips would be very much appreciated please.