Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: Indexer PP issue

  1. #11
    Join Date
    Jun 2019
    Posts
    31

    Default

    This is the top of the SBP file.
    For some reason I am unable to copy and paste that file here.
    grinder SBP file.jpg

  2. #12
    Join Date
    Dec 2000
    Location
    Thorp, WI
    Posts
    2,759

    Default

    Post your cut file. The supposed problem is happening when the cut file calls up ShopBot's manual tool change file. If you were to comment out (') those calls in the cut file, how does it run then?

    Be sure to do this as an air cut, just in case.

    "He who would trade liberty for some temporary security, deserves neither liberty nor security" - Benjamin Franklin
    "Make yourself sheep and the wolves will eat you" - Benjamin Franklin




  3. #13
    Join Date
    Jun 2019
    Posts
    31

    Default

    Quote Originally Posted by srwtlc View Post
    Post your cut file. The supposed problem is happening when the cut file calls up ShopBot's manual tool change file. If you were to comment out (') those calls in the cut file, how does it run then?

    Be sure to do this as an air cut, just in case.
    Please excuse the ignorance, I am totally new to G code.
    Comment out the call?

    I cannot copy/paste the cut file, this forum will not allow it, the paste function is grayed out.
    Neither is there an icon to attach a file, only to attach a picture or video link.
    How can I post this file?

  4. #14
    Join Date
    Dec 2000
    Location
    Thorp, WI
    Posts
    2,759

    Default

    Choose to reply to thread and in the lower right, click "Go Advanced". Once there, scroll down an use "Manage Attachments" and attach your file through that.

    "He who would trade liberty for some temporary security, deserves neither liberty nor security" - Benjamin Franklin
    "Make yourself sheep and the wolves will eat you" - Benjamin Franklin




  5. #15
    Join Date
    Jun 2019
    Posts
    31

    Default

    Quote Originally Posted by srwtlc View Post
    Choose to reply to thread and in the lower right, click "Go Advanced". Once there, scroll down an use "Manage Attachments" and attach your file through that.
    This is the SBP file.
    It will not allow me to upload the Aspire file, I get an error that it is an invalid file type.
    The Aspire suffix is .crv3d so I changed it to .crv thinking it does not like the "3d" and you could just add it back on, but that does not work either. It tells me that .crv is also invalid file type.
    Attached Images Attached Images

  6. #16
    Join Date
    Dec 2000
    Location
    Thorp, WI
    Posts
    2,759

    Default

    You can change it to .txt and then we can change it back to .crv3d or add it to the extension already there. The sbp file is just a screen grab, so try generating just a one tool file and then open it in the editor like you have there and put an apostrophe (') in front of the C9 and save. Do a find/replace to see if there are any other C9's.

    After that, zero out your tool manually like you normally would to start with and run the file (air cut with no tool). If it works/runs as expected, it's not your PP for VCP/Aspire, it's ShopBots own MTC file that is causing the problem. If they can't figure it out from that point, they can send their 6 week paycheck to me and I'll dig deeper.

    Yes, it that C9 is not there, the cut file will not ask you to change a tool, so you'll have to make separate toolpaths.

    "He who would trade liberty for some temporary security, deserves neither liberty nor security" - Benjamin Franklin
    "Make yourself sheep and the wolves will eat you" - Benjamin Franklin




  7. #17
    Join Date
    Jun 2019
    Posts
    31

    Default

    Quote Originally Posted by bobmann View Post
    Please excuse the ignorance, I am totally new to G code.
    Comment out the call?

    I cannot copy/paste the cut file, this forum will not allow it, the paste function is grayed out.
    Neither is there an icon to attach a file, only to attach a picture or video link.
    How can I post this file?
    So I deleted the C9 command in a part file, and the A & B axis did not change when I started the program.

    This solves the problem of the indexer moving when a program is called up.
    The downside is that I will have to create a new cut file for each tool in the program, not that big a deal as I typically only have a few tools in a program. At least I can use it now.

    Thanks all for the assistance.
    Perhaps Shopbot will come up with a fix that will allow for a manual tool change.

  8. #18
    Join Date
    Dec 2000
    Location
    Thorp, WI
    Posts
    2,759

    Default

    Go to your C:\SbParts\Custom\MTC folder and attach the MTC.spb file you have. That is the file that is causing it.

    "He who would trade liberty for some temporary security, deserves neither liberty nor security" - Benjamin Franklin
    "Make yourself sheep and the wolves will eat you" - Benjamin Franklin




  9. #19
    Join Date
    Jun 2019
    Posts
    31

    Default

    I found these in C:/Shopbot Support/custom/mtc
    Attached Files Attached Files

  10. #20
    Join Date
    Dec 2000
    Location
    Thorp, WI
    Posts
    2,759

    Default

    Just for curiosity sake, what is your B axis unit value set to? (VA, Values Units, B Unit Value)

    In both your videos, the MTC script is falling through the "Safe 5 axis" sub when it should be branching to the "Safe 4 axis" sub, which is meant to ignore the B axis.

    "He who would trade liberty for some temporary security, deserves neither liberty nor security" - Benjamin Franklin
    "Make yourself sheep and the wolves will eat you" - Benjamin Franklin




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •