View Full Version : Limit switches - lights are on but nobody "home"

01-14-2006, 12:07 PM
Need a bit of help here...

My proximity switches are turning on when they hit the stop (all 3 axes) and the input light on the computer screen turns on BUT the bot doesn't stop...

This would indicate to me that the switches and cabling are fine and the problem is on the control board or software...


01-14-2006, 12:12 PM
Hey Roy,

Are your prox switches connected to input #3? That's the only input that works as a limit switch, to stop the tool when it's turned on.


01-15-2006, 12:20 AM

They have been connected to #3 for about 3 years or so <G>...and nothing has changed. So...figuring it had to be a software or controller issue, I started with things I could do myself...I updated to .16 version, reloaded firmware, etc...still no joy...until

I found another reference to a similar problem posted here in which the Input (VN?)had been switched to standard instead of limit in the software. I checked my settings and found they were still showing as limit but being the kind of person who turns a switch just for the heck of it, I switched to standard and then back to limit....

Funny thing...everything works now...

Back to my intermittent life....<G>


01-15-2006, 09:50 AM
Roy, I have had the same problem. My cure came when I realized that one of the limit switchs was hit first then after pushing the resume button for the negative X move the gantry just kept going.

I have found that if one of the limit switches has been hit and stays lit, the software does not see the second hit and just keeps moving.

Hope this helps. Jay

01-15-2006, 09:06 PM
I also have just setup my Bot and the limit switches both light up red, the #3 light on the computer is "yellow" (i am guessing it should be green), then when I move the x car, for some strange reason the yellow light on the computer changes to a yellow light with a red x in the center. This is getting bizzare.

Any suggestions/

01-15-2006, 09:24 PM
Nevermind my last post. I read Roy's 2nd post from the top and did the same thing... set VN to 0, then to 1 and the switches worked. Must be a software reset thing.

And Jay is correct that when one switch lights and you move the other axis it doesn't stop. I guess the homing routine takes care of this by hitting both at the same time... I think.

01-15-2006, 09:29 PM
Mike, the limit switches are not hit at the same time. The routine is set up to zero the 'x' axis first then to zero the 'y'.

01-15-2006, 11:13 PM
Thanks Jay. I found that out after I reread the manual. It is all clear now.

01-16-2006, 11:48 AM
I'm thinking that all is clear now??

We have been trying to duplicate Roy's original issue up above: where VN and the little vertical bar in the limit indicator show that the limit switches are ON and acting as limits, but they don't stop the tool. We've tried a number of different scenarios and have not been able to duplicate.

So, if there is a way to make it happen, let us know so we can get it fixed. Send along a description of how you do it, and your PROBLEM.LOG so we can duplicate the set-up.

-Ted Hall, ShopBot

01-16-2006, 02:15 PM
I see that Roy is also in NC - can't a technician from SB call on him to check it out? Techies need to get out of their comfort zone and visit the real world.

01-17-2006, 12:33 AM

I was operating with the position keys (K) and moving the gantry to change out the tabletop. Tabletop was removed and gantry left in position overnight (did I power down the control box with the gantry over the stop ??? don't know!!). Replaced the top, powered up, and was checking to make sure I had full coverage...ran the router down the lower Y when it hit the stop...it didn't. Checked all other limit switches and none of them stopped the router although the lights lit and the #3 indicator went to yellow.

Set the VN to Standard and then back to Limit...everything started working again...

Hope this helps...