View Full Version : Zzero help

07-31-1999, 08:51 PM
I have set up my SB using ver 2b10 software and zzero_v2.
If I ground the plate the input switch registers as it should.
The grounding plate is connected to P1.4 on the terminal board.
I am using the unused orange wire in the cable that connects to the Z motor to attach to the plate.

The problem:
When running the zzero program, just after it starts, the input switch is triggered and the program completes normally.
The router bit never reaches the plate.

Thanks for any help.

Rick Samish
08-02-1999, 05:21 PM
Problem solved
The wire in the cable to the Z motor recieved a magnetic charge from turning on the Z motor.

A seperate wire solved the problem.

Thanks Doc

12-25-2000, 07:36 PM
I have just recently finished construction of the steel table shopbot. the problem I,m having is : when running the part file vacc4, to create the channels for the vacuum table, it does not appear to be calibrated for the size of the mdf board. I know the measurements off mdf are an inch greater than ply, and thought this would help. I zeroed the machine and did an "air cut", and the carriage still offsets the quadrants.
I assume the partfile vacc4 would create 4 equal zones, the machine would like to run off the x rails towards the end of the program. please help me!

12-26-2000, 09:37 AM
what do you mean by 'offsets the quadrants'?


12-27-2000, 09:18 AM
Check your unit values (VU) and set them according to your number of pinion teeth.
xy-127.3240, z-1018.592 for 20 tooth pinions
xy-141.4711, z-1131.7688 for 18 tooth pinions.
The manual has them backwards. Mine was not set correctly and wasn't moving the right distance. Unless I'm understanding you incorrectly.

03-01-2002, 12:18 AM
I am trying to use the VI command in a part file and it's not working. I want to make a custom file to zero my acc axis. It works on the fly but not in a file.

Ted Hall, ShopBot
03-01-2002, 10:10 AM
Hi Bill,

As per my email to you ... send along the file so we can check it out. You should be able to do just what you want.

(I'll try to remember to post here what we figure out).

Ted Hall, ShopBot Tools
03-02-2002, 04:06 PM
Hi Bill,

Here's what I think the problem is ... After a ShopBot Command, there needs to be either a space or a comma that acts as a seperator of the command from the parameters. We typically use a comma for consistency. After this comma or space, the first parameter occurs. This means that in your file version of the VI command the "3" & "4" are actually in the 6th and 7th parameter position, while they need to be at the 7th and 8th. In other words, you are short one comma. I think you'll find that takes care of it.

I realize this is a bit confusing because when you enter a command from the keyboard, the seperator is put in automatically ... so you typically use one less comma than in a file.

Have a look at the 'Record' function which, if you enter a couple of VI commands will generate a file using the Commands that you have typed in ... this file will have that extra comma.

You can also check the current condition of the Z and Acc axes assignments with the [UV] command, if you have not already discovered it.


> To: Ted Hall
> Subject: RE: web tech support request
> Ted,
> I save zzero.sbp as zzeroa.sbp and add to lines VI,,,,,,4,3 at the
> beginning and VI,,,,,,3,4 just before the end command to zero
> my acc axis. I
> am sending the file to you along with the problem.log. I
> underlined and
> highlighted the lines in read. From the move screens I can type in
> VI,,,,,,4,3 and then C2 and it works fine, but not if I put
> it in a file. I
> also created a custom 4 file to zero my acc axis and tried to
> put the VI
> command at the beginning and end of it but it didn't work either.
> Bill VG