View Full Version : ShopBot stops after 30 minutes

10-26-2002, 10:39 PM
Hey folks, I'm having a hard time with one of my new machines. This one is run by my old 486 computer using WIN95. The problem is that every thirty minutes or so the SB-CUT window get's minimized and the machine stops. The window starts out in full screen, I have turned all power management settings off, no screensaver, the icon properties are set to "don't allow screensaver" and "pause background", there are no recurring tasks and all of the off-line selections for Internet Exploder have been turned off.
When the machine stops, the desktop is displayed on the screen. If I touch the mouse, the screen goes back to the ShopBot program and the tool starts moving again.
I just went out and turned down the speed on the FIFO buffers for COMM 1, but I don't think that's it. I wonder if I have an old DLL from the screensaver program I used to have....Hmmmm.....

Anyway, If anyone has any ideas, your help would be appreciated.



10-26-2002, 11:19 PM
Hwy Chip,

Just a thought,

check your display settings to make sure you don't have some sort of power management settings checked.

look in control panel/display/settings/advanced

Hope this helps.


10-27-2002, 12:40 AM
You said that you disabled the power management in the control panel...restart the machine and make sure that the power management is disabled in the BIOS. I know that sometimes the BOIS will override the Windows configuration in 95 and 98 (98 2nd Edition doesn't do this).

Generally, the screensaver won't just activate if you have it turned off. Another possibility is that there could be an aftermarket program or screensaver that is running in the background. Do a Ctrl/Alt/Del on it one time, and see what is running. If there is something in there that shouldn't be, you can either find the program and delete it, or go to Start/Run: MSCONFIG. This will allow you to disable anything that is 'invisible' and running in the background if it is an exe.

Hope that helps.


10-27-2002, 01:51 AM
A 486 computer running a new (late model?) Shopbot plus Windows 95 sounds like a bad mismatch IMHO. You are expecting too much from a 486 computer.

At minimum, I would check the BIOS and reformat the hard drive so that the PC boots in DOS only. Even these drastic steps were not enough to get full performance out of our 2 year old PRT SB on a 486 PC.

10-27-2002, 08:47 AM
I had previously checked the BIOS and shut off all of the power schemes there. The display settings are correct. So I go that stuff covered...
The 486 that I am using is a DX4-120, so it's pretty fast. I can put the virtual memory on the data drive and increase it a bunch, but it is already at about 500 meg. I have a hard time believing that this computer would not be able to run the shopbot. It was faster than the "new" Pentiums when they first came out. I am gonna try to run it in DOS mode this morning... But first, I am going to scour the .INI files to see if anything screwy is getting loaded. I thought that I had left all of this stuff behind when I bought my first Pentium II...

Good note on that, though!! I was able to save $600 on buying new computers by using my old ones! This problem notwithstanding, I have justified lugging my two old PC's from Hawaii to San Diego and to New Jersey! Too bad I'm not married and can't gloat to my wife...

10-27-2002, 10:23 AM
Chip, if you do a simple motor speed test (verified using tape measure and stopwatch - not "displayed"), do you achieve the published specs of:

XY Move Speed 120"/min. (3.05m/min.)
XY Positioning (Jog) Speed 240"/min. (6.10m/min.)

My 486 was falling way short of this, even in pure DOS. When I changed to an old Pentium, I reached the speeds, plus the movements were a lot smoother. I don't know about actual chip types etc, but I do know that the Pentium was 2 years later in the state of the art.

10-27-2002, 07:49 PM
Guys, thanks for all of the tips. I went into the ini files and deleted all of the unecessary garbage and redundant entries. I took out lines from old programs and then I deleted and reloaded the mouse...and it works! There were a bunch of dead programs in there, but the mouse strikes me as the culprit. For one thing, I have two serial cards in there and all of the comm ports are on thier own IRQ. While the mouse was working, the computer kept trying to communicate with it through COM 1, which is where the ShopBot is. That would *probably* explain why the program went back to working when the mouse was disturbed. Could be...I can't really tell since I did several things at once... Oh well...

The Bot works very quickly with the 486. I am cutting files at XY 2.25, Z 1.5. While that may not be quick for some of you, I could only cut at XY .8, Z .4 on the old machine. I'll try the test you specified, Gerald. I think that this motherboard is upgradeable to a pentium...or one on a daughterboard, anyway... I'll let you know.

Thanks again, folks... I appreciate the help!


10-28-2002, 06:33 PM
Spoke too soon. It is doing it again. It worked fine for a smaller file...maybe a memory thing. I'm still looking...

10-29-2002, 03:37 AM
Gerald is correct.
Ron V

10-29-2002, 08:57 AM
I doubt if I am totally correct - I think that Chip knows what he is talking about. He already showed that he can get the right speeds (in inches per second)

Zac R.
10-30-2002, 03:29 PM
hey chip, this is zac at shopbot. just reading through for the heck of it. same thing happened to me here in the shop running my Z axis tests. now we have fixed it since, but it was a while back and im racking my brain trying to remember how we did it. im gonna go ask around and see if anyone can remember how we fixed it and ill try to get back to you with an answer, if you havent already fixed it.

Zac R. - shopbot
10-30-2002, 03:49 PM
ok, think this might work. if you have already done it than disregaurd this message. try going into the control panel, go into power options and check those settings. what this does is set a time when the hard disk or the monitor will set itself to stand by. im not positive that this is what i did, but it was the first thing ive come across. ill check back

10-30-2002, 05:39 PM
Zac, that was the first thing I tried. I went everywhere and shut off everything. I even went into the bios and shut off the power routines there. It is a pretty strange problem. One thing that the 'Bot does is pause frequently to load instructions into the buffer. The further along the computer goes, the more frequent the stops. Maybe the buffer stops working... When I touch the mouse and the control screen comes back on, it quickly loads several hundred lines of code before the tool starts moving.

Just to make sure it isn't memory, I purchased eight 30 pin 16 MB simms ($10 each... I remember when they were several hundred dollars apiece). Hopefully the problem will go away. I'll let you know when I do that, but don't hold your breath... I leave on Friday for a week in Disney World.

Thanks for the help Zac! I appreciate your input - everyone elses too, while I'm at it...


10-31-2002, 12:44 AM
"One thing that the 'Bot does is pause frequently to load instructions into the buffer"

That seems to be quite normal. But the screen shouldn't blank out, and you don't have to kick the mouse's butt to get it going again. The frequency of the stops is also not dependent on how far along the program is.

10-31-2002, 08:33 AM
Yes, all of my machines do this. I just keep throwing ideas in ther air...

Zac R. - shopbot
10-31-2002, 08:55 AM
well its possible that its some kind of windows interference. my computer here has win95 as well which could possibly have something to do with it, but dont hold me to that. ill talk with Gordon or Ted today when they get in and see what we can come up with.

10-31-2002, 09:05 AM
Chip, that loading of data in block sessions is referred to in the manuals and on this forum - that in itself is a correct function, so don't assume that this is part of your problem.

Michael Kuhrau
11-06-2002, 02:11 PM
Chip, check your keyboard. I had the same problem, had too much junk in the keyboard. One of the keys got stuck and caused the shrinking window when pushing ENTER.
Took the keyboard apart, cleaned it and everything worked fine.