View Full Version : Turbocad problems...

07-25-1999, 04:54 PM
Help! I have been using Turbocad(versions 4 and 5) on my machine for months now. Yesterday I "cleaned"out a few old programs off of my machine, and right after that I tried to open Turbocad and I was greeted with "this program has performed an illegal operation and will be shut down"! I couldn't get either version to open, so I uninstalled the both of them, and tried to re-install them from the cd's. Neither one will install past the point of "this program has performed, etc, etc.."
I am wondering if anyone else has had this problem, and solved it! One of the programs I had removed was an old CAD program (Keycad pro), but even if that "took"shared files with it, shouldn't I have been able to re-install cleanly from the CD?
I would appreciate ANY ideas you can send in this direction, thanks...Bill P.
b1705@bellatlantic.net (mailto:b1705@bellatlantic.net)

07-25-1999, 05:34 PM
I had the identical problem after installing some new software. It turned out a newer version of the file MFC42.DLL was installed which TurboCad can't work with. I'll email you the original MFC42.DLL (save the one you currently have first!) so you can give it a try. You often can't replace these files from within Windows (will say it is in use) so you'll need to "Restart in MS-Dos mode" first.

07-26-1999, 12:27 PM
Robin, I saved the file you sent me, then I went to Turbocad's support site and found that I was one of MANY people having this problem! I followed the advice of their support tekkie and copied the "old"mfc42.dll into the 'program"folder of the Turbocad program(s). Before doing this neither of them would open, but immediately after doing so I am back up and running!!!
Needless to say this has saved me considerable anxiety...It is in situations such as this that I really appreciate the Shopbot community, and the access to this Forum. Hope I can pass along the favor to someone in the future...Bill P.