View Full Version : Unable to ungroup after DXF import

03-31-2006, 02:58 PM
Hey everyone,

The other day I was trying my hand with Part Wizard. After I import a DXF file I do a first Ungroup, but then I still have subsets of vectors that appear to be grouped because they all get selected when I click one of them. I can't seem to be able to Ungroup these smaller sets of vectors.
What gives?


03-31-2006, 04:07 PM
Aren't they attached (look closely at nodes in node editing mode)?

I'm not sure this is relevant to PW but could they be locked (grey color)?

What is the color of the selection? If it's pink, you have one vector selected, if it's purple, you have two or more...

03-31-2006, 09:15 PM
The selection is black and this is what my edit menu looks like:


Brady Watson
03-31-2006, 09:26 PM
When you pull in your vectors it sounds to me that they are groups of groups...So by just selecting ungroup, you only remove the overall grouping...not sub-groups.

Before this gets really confusing, just import your DXF, and immediately right click on it and select "Ungroup All". This will get you where you want to be.


03-31-2006, 11:01 PM
Yes, that should fix the problem (unless there're attached). Right on Brady!

04-01-2006, 12:35 AM
Thanks Brady, but I don't have "ungroup all" when I right click. All I have is a "Ungroup Vector(s)" which is the command I used before.

Here is my right click menu:


04-01-2006, 10:07 AM
I suspected this when I hit 'Post' last night...

So when you select 'em all (CTRL-A), what color are they? Aren't they attahced in some way?

You may want to follow Brady's idea that it's grouped groups (can I write this?) and select 'em all, hit CTRL-U a few times...

04-13-2006, 02:10 PM
Hey guys,

Here are a few pictures that might help understand.

Here is just after importing my file:


Now I ungroup. Then when I try to click on different single segment I get:

A first strange group:


A second stange group:


A third strange group:


and finaly I found a single segment:


any suggestions?


04-13-2006, 03:33 PM

I'm not 100% sure what is going on with your drawing but I suspect crossing lines... from what CAD is it from? Generaly, ArtCAM prod. import correctly (don't modify the design... or simply don't import at all) and more often it's the export (save as) process that scramble the design from CAD software.

If you want, you can send me the file and I get you a more accurate diagnostic and even repair...

04-13-2006, 03:48 PM
This being PartsWizard, I don't have a clue about all the instructions. But I am wondering if your imported dxf file has duplicate line segments - placed exactly one of top of the other?

(PS. These screen captures are better in .gif format than .jpg)

04-14-2006, 10:33 AM
I believe the drawing was made in SolidEdge 18 then exported to DXF 14. I would be surprised if ArtCAM could import directly from SolidEdge, but who knows. The thing is though, I have many drawings to toolpath so I am very much interested in figuring out where the problem comes from. I'll e-mail you a file later.

I checked and all segments are unique.
About the screen captures, do you mean visual quality or file size?

04-14-2006, 10:56 AM
File size (loading time) definitely, quality too in some cases. This forum posts both formats.

04-15-2006, 09:08 AM
I don't know if this post will make sense but I agree with gerald it looks like you may have lines on top of lines and also possibly that you have grouped items which are also within another group. Ie: Line A and B are grouped together and this group is then grouped to Line C.

04-15-2006, 09:35 AM

Without seeing the file I will have a guess that some of the line might be drawn on different layers....
Have a look.


04-15-2006, 09:57 AM
This thread (http://www.talkshopbot.com/forum/show.cgi?tpc=31&post=32561#POST32561) has a couple of pointers of what could be "unfriendly" in a dxf file.

04-15-2006, 10:04 AM
Does PW handle groups of groups? ie. multiple levels of grouping that AutoCAD, for example, can give you?

04-15-2006, 11:16 AM
SolidEdge is a 3D CAD so that might explain part of the "problem"... still, it shouldn't be much of a hassle to sort it out since the drawing ain't so complexe... but it all depend on J-F's goal on this particular project.

04-21-2006, 06:34 PM
I also tried the files coming out of Ashlar Cobalt and I got the same problem. I tried DXF12, DXF 14, DXF2000, with the results each time.

My goal was to use PartWizard to create the toolpath. Now with this problem in the way, I wanted to understand why it wasn't working so that I could fix the problem.

In the mean time, Bill Young suggested I create a seperate drawing for each toolpath. I seem to be able to replicate that strategy so that's what I'll do for now. I would still like to understand where the problem comes from.

04-22-2006, 10:49 AM
It ain't easy to help you more without having the file... I share that feeling that you want (need) to understand what's going on; I often feel the same...

04-25-2006, 12:16 PM
Maybe this is just a selected closed vector and not a group that he is refering to. PW makes closed vectors out of your dxf files if it can. Sometimes when I bring in an autocad DXF file but I forget to make the file closed polylines before saving in DXF I get some weird shapes in PW. I don't think he is selecting a group in the second and third screen shot but selecting a closed vector.